Mobile app system requirements

This article describes the minimum system requirements to run the Achieve Client App, the Elevate Staff App, and WellnessLiving’s web apps which include: the Client Web App, Client Self Registration App, Attendance Web App, and the Client Self Check-in App.

To learn about the minimum system requirements for WellnessLiving, see WellnessLiving system requirements.

In this article:

iOS requirements

The Achieve Client App and all WellnessLiving’s web apps require iOS 8.0 or higher. The Elevate Staff App requires iOS 11.2 or higher. They are compatible with the following iOS devices:

  • iPhone 5S or later
  • iPad Air or iPad Air 2
  • iPad Mini 2 or later
  • iPad Pro (1st generation) or later
  • iPad (5th generation) or later
  • iPod touch (6th generation)

Android requirements

The Achieve Client App, Elevate Staff App, and all WellnessLiving’s web apps require Android 5.0 or higher.

Was this article helpful?
(63 out of 64 people found this article helpful)
Still need help? Contact us
Cancel